LibraZiK bugtracker

Notice: Undefined index: tasklist_type in /data/web/71/14/dc/librazik.tuxfamily.org/htdocs/flyspray/includes/class.tpl.php(128) : eval()'d code on line 85 Notice: Undefined index: tasklist_type in /data/web/71/14/dc/librazik.tuxfamily.org/htdocs/flyspray/includes/class.tpl.php(128) : eval()'d code on line 90
  • Etat Assigné
  • Pourcentage achevé:
    70%
  • Type de tâche Demande de fonctionnalité
  • Catégorie distribution → nouveau logiciel
  • Assignée à Administrateur (trebmuh)
  • Système d'exploitation
  • Sévérité Basse
  • Priorité Normale
  • Basée sur la version version 2 20181115
  • Due pour la version Non décidé
  • Date d'échéance Non décidé
  • Votes 0
  • Privée Non
Concerne le projet: LibraZiK bugtracker
Ouverte par Administrateur (trebmuh) - 2018-12-09
Dernière édition par Administrateur (trebmuh) - 2019-08-12

This task does not depend on any other tasks.

Nico Faure (Sub26Nico)
samedi, 09 février 2019, 15:54 GMT
J'ai tenté une compilation il y a quelques temps, j'ai une erreur pour la dépendance Suil:
"sub26nico@debian:~/zrythm$ ./configure
checking build system type... x86_64-pc-linux-gnu
checking host system type... x86_64-pc-linux-gnu
checking for gcc... gcc
checking whether the C compiler works... yes
checking for C compiler default output file name... a.out
checking for suffix of executables...
checking whether we are cross compiling... no
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ISO C89... none needed
checking for pkg-config... /usr/bin/pkg-config
checking pkg-config is at least version 0.9.0... yes
checking for GTK3... yes
checking for JACK... yes
checking for LILV... yes
checking for SUIL... no
configure: error: Package requirements (suil-0 >= 0.10.0) were not met:

Requested 'suil-0 >= 0.10.0' but version of Suil is 0.8.4

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables SUIL_CFLAGS
and SUIL_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details."

La question de faire des paquets pour les Debian plus vieilles que Buster c'était posé, mais le dev a renoncé :
https://gitlab.com/alextee/zrythm/issues/46

Il faut attendre les prochaines Debian et LibraZiK (/me croise les doigts ;-) )
Nico Faure (Sub26Nico)
samedi, 04 mai 2019, 20:11 GMT
En fait le dev est revenu sur sa décision et maintenant zrythm compile correctement, il y a même des binaires dispos pour la plupart des distros 'classiques'.
À l'heure actuelle le logiciel est encore assez loin d'une version stable, le dev bosse dessus chaque jour donc ça devrait arriver d'ici quelques mois.
Je teste assez régulièrement les avancés donc je ferai signe quand ça sera utilisable. J'ai fait la traduction du logiciel (pour les fonctionnalités du moment),
ça sera déjà ça moins à faire ;-).
Administrateur (trebmuh)
samedi, 08 juin 2019, 14:14 GMT
Note pour moi même : (un bout de règles d'empaquetage debian) https://build.opensuse.org/package/show/home:alextee/zrythm#
Administrateur (trebmuh)
lundi, 12 août 2019, 13:57 GMT
Une version 0.5.162-1librazik1 et disponible dans testers.
Retours bienvenus.
Administrateur (trebmuh)
lundi, 12 août 2019, 14:30 GMT
Il enregistre la configuration des projets dans ~/zrythm/ (par défaut).
Administrateur (trebmuh)
mardi, 13 août 2019, 18:31 GMT
Une version 0.6.003-1librazik1 et disponible dans testers.
Retours bienvenus.
Administrateur (trebmuh)
mardi, 13 août 2019, 19:07 GMT
Une version 0.6.003-1librazik2 et disponible dans testers.
Elle apporte le support des MP3, ainsi que la possibilité de voir les IGU de la V1suite normalement.
Retours bienvenus.
Nico Faure (Sub26Nico)
mercredi, 14 août 2019, 08:15 GMT
Cette nouvelle version fonctionne ici, alors que la précédente ne se lançait pas ( version 0.6.003-1librazik1). Les IGU de la V1suite s''affiche correctement.Par contre, si j'insère un mp3 (à partir du navigateur) dans la fenêtre d'arrangement (ce qui devrait créer une piste AUDIO), le logiciel plante. Je fais remonter l'info au dev.
Administrateur (trebmuh)
mercredi, 14 août 2019, 10:48 GMT
Note : il enregistre sa configuration dans /usr/share/glib-2.0/schemas/org.zrythm.Zrythm.gschema.xml
Administrateur (trebmuh)
jeudi, 22 août 2019, 17:24 GMT
Une version 0.6.039-1librazik1 est disponible dans testers.
Elle apporte une doc intégrée en html dans /usr/share/doc/zrythm/fr/index.html
Retours bienvenus.

Chargement...