LibraZiK - Accueil
Don
Cliquez ici pour donner sur le compte liberapay du projet
LibraZiK - summary in english

Outils pour utilisateurs

Outils du site


manuel:installer_librazik:lzk1_vers_lzk2

Installation de LibraZiK-2 - Mise à jour d'une LibraZiK 1 vers une LibraZiK 2

Était en cours d'écriture au 17 novembre 2017. A été abandonné car non-fonctionnel.

Si vous décidiez quand même de l'utiliser, c'est à vos risques et périls.

Si ça fonctionne, merci de venir le signaler.

Avant-propos

Cette page décrit une manière fonctionnelle de mettre à jour un système LibraZiK-1 vers une système LibraZiK-2.

Il est bien évidemment conseillé de faire une sauvegarde complète de son système avant toute chose.

Ensuite, une lecture des notes de publication de la version 64 bits 1) vous permettra de ne pas faire de grosses erreurs. Veuillez noter que le chapitre 4 concerne précisément la mise à niveau à partir de la version Jessie vers la version Stretch, ce qui nous intéresse particulièrement ici.

Préparation

Ensuite, avant de démarrer la migration de LZK-1 vers LZK-2, vérifier que votre système LZK-1 est parfaitement à jour en faisant une dernière mise à jour de votre système LZK-1 2).

Ensuite, il vous faut mettre à jour la liste des sources. Pour cela :

  • démarrez Synaptic puis aller dans menu Synaptic → Configuration → Dépôts
  • modifiez les lignes :
    • debian : jessie par stretch
    • librazik : premierpas par decepas
    • distribution : LZK-PP par LZK-DCP
  • cliquez sur le bouton Valider
  • fermez Synaptic
Si vous vouliez effectuer le remplacement directement en ligne de commande, les différents fichiers se trouvent dans /etc/apt/sources.list.d/, ainsi que le fichier /etc/apt/sources.list.
Si vous aviez des adresses de dépôts du type “httpredir.debian.org”, il vous faut les remplacer par “deb.debian.org” qui est le service équivalent, httpredir ayant été abandonné par Debian.

Mise à jour

Cette mise à jour se fera dans un terminal grâce aux commandes suivantes :

  • su -c "apt-get update" : mise à jour des fichiers d'index des dépôts
  • su -c "apt-get upgrade" : mise à jour minimale du système
  • su -c "apt-get install rdnssd" : mise à jour de ce paquet particulier (sinon l'étape suivante ne passe pas)
  • su -c "apt-get dist-upgrade" : mise à jour principale du système
La patience sera votre bonne amie ici car ceci peut être un peu long 00:22 → .

Redémarrage à la fin (pour prise en compte du nouveau noyau entre autres).

Vérifications

cat /etc/debian_version
→ doit retourner “9.quelquechose”

lsb_release -a
→ doit retourner quelque chose comme :
Description: Debian GNU/Linux 9.2 (stretch)
Release: 9.2
Codename: stretch

Vérifications du fait que les paquets librazik-keyring , librazik-apt , librazik-base-all , librazik-mate-all , librazik-optimisations-all , et librazik-theme-all sont bien installés et bien dans leurs bonnes versions “2 ou supérieur”.

Configurations

Virer les vieux noyaux + installer un noyau BL ou RT pour LZK2. (ça devrait remettre d'aplomb le menu Grub de démarrage en virant les références aux anciens noyaux).

Conclusion

Et voilà !!!

Si vous en avez la possibilité, une installation à partir de zéro peut également être une bonne idée car elle a le mérite de ne pas traîner de vieux fichiers de configuration.

Notes

Paquets-logiciels qui :

  • disparaissent : dino, easytag, non, non-sequencer, pd2lork, sineshaper, composite
  • changent : xchat → hexchat






Note de construction du tuto : une fois terminé, ajouter les tags “tutoriel” et “tutoriel système”.
2)
ou : apt update && apt upgrade && apt dist-upgrade en ligne de commande
manuel/installer_librazik/lzk1_vers_lzk2.txt · Dernière modification: 04/01/2018 23:12 par trebmuh