LibraZiK - Accueil
Don
Cliquez ici pour donner sur le compte liberapay du projet
LibraZiK - summary in english

Outils pour utilisateurs

Outils du site


manuel:creer_une_session_raysession_avancee

Manuel de LibraZiK-3 - Créer une session RaySession avancée

Ce tutoriel a été revu pour la dernière fois en septembre 2020 sur LibraZiK-3 avec les paquets raysession 0.9.2+20200910-0librazik1, catia 0.9.1+20200914+fr-0librazik2, zynaddsubfx 3.0.5-0librazik3, hydrogen 1.0.1-0librazik2, ardour 1:6.3.0+ds0-1librazik1, et pluma 1.20.4-1.

Avant-propos

Nous avons vu dans le tutoriel précédent 1) comment utiliser RaySession pour une session de travail simple.

Nous allons étudier un exemple plus complexe dans ce tutoriel où nous allons utiliser RaySession avec Hydrogen, ZynAddSubFX et Ardour afin de créer une session RaySession qu'il sera possible de rappeler ultérieurement et qui relancera toutes les applications, leurs pré-réglages, ainsi que leurs connexions en un seul coup.

RaySession avec : Hydrogen, ZynAddSubFX, Ardour et un clavier MIDI - cliquer pour agrandir

Prérequis

Les prérequis sont :

  1. les paquets cadence, catia, raysession, hydrogen, zynaddsubfx et ardour installés
  2. Cadence correctement configuré et démarré 2) sur une interface audio
  3. un clavier maître MIDI USB et qui a déjà été testé fonctionnel sous LibraZiK-3

Action

Préparer une nouvelle session RaySession

Avant toute chose, assurez-vous avec Cadence que JACK soit lancé. Ce n'est pas primordial pour RaySession en lui même, mais pour Hydrogen, Ardour et ZynAddSubFX, si !

Il nous faut maintenant préparer une session RaySession.

Pour cela, lancez RaySession : Menu LZK → Applications → Son et vidéo → Outils JACK → RaySession
Vous arrivez à présent sur la fenêtre principale de RaySession : RaySession à son démarrage - cliquez pour agrandir

Cliquez sur le bouton “Nouvelle session” (en haut à gauche) puis nommez votre session dans la fenêtre de dialogue qui apparaît : Fenêtre "Nouvelle session" de RaySession - cliquez pour agrandir

Laissez le modèle “avec mémoire du patch de JACK”, puis cliquez sur le bouton “OK”.

Un client est apparu dans la liste des clients de RaySession qui s'appelle Connexions JACK. C'est lui qui sauvegardera les connexions de JACK. Fenêtre principale de RaySession avec la session démarrée et le client "JACK Connexions" - cliquer pour agrandir

Lancez Catia afin de voir vos connexions JACK : Menu LZK → Applications → Son et vidéo → Outils JACK → Catia
Vous devez y voir les connexions matérielles de votre système (entrées et sorties de carte son) : Vue du matériel dans Catia - cliquez pour agrandir

Si vous souhaitez faire apparaître le clavier MIDI USB 3), allez dans le menu Catia → Outils → Pont ALSA-MIDI → Démarrer le pont : Vue du matériel dans Catia avec le MIDI - cliquez pour agrandir

Lancer les applications souhaitées dans la session RaySession

Nous allons à présent lancer la première application dans la session RaySession.

À ce stade, il est important que vous compreniez que, lors de l'utilisation d'une session RaySession, il vous faut absolument démarrer les applications à l'intérieur de la session RaySession 4) .

Pour cela, cliquez sur le bouton “Application” (ou Ctrl+A). Vous verrez alors apparaître cette fenêtre de dialogue : RaySession : choisir des applications à lancer - cliquer pour agrandir

Lancer Hydrogen dans la session RaySession

Dans cette fenêtre ainsi ouverte, déroulez la liste des applications jusqu'à apercevoir “Hydrogen”, puis double-cliquez sur dessus.

La fenêtre de dialogue des applications se ferme, le logiciel Hydrogen se lance et le client “Hydrogen” a été ajouté à la liste des clients de RaySession.

Si vous revenez à la fenêtre de Catia, vous voyez maintenant les ports de connexion audio et MIDI du logiciel Hydrogen qui sont apparus et dont les deux ports audio se sont automatiquement connectés au matériel audio : Catia : vue avec Hydrogen et ses connexions - cliquer pour agrandir

Lancer ZynAddSubFX et Ardour dans la session RaySession

Lancez le synthétiseur logiciel ZynAddSubFX et la STAN Ardour de la même manière que vous avez lancé Hydrogen. Les ports audio de Ardour s'auto-connecteront également au matériel audio. Il faudra en revanche connecter dans Catia les sorties audio de ZynAddSubFX au matériel audio.

Catia avec Hydrogen, ZynAddSubFX, et Ardour lancés, ainsi que leurs connexions - cliquer pour agrandir

Lancer Pluma dans la session RaySession

Nous allons ici faire un exemple pour une application ne figurant pas dans la liste d'applications de la fenêtre de dialogue des applications de RaySession. L'exemple choisi est le logiciel Pluma, un simple éditeur de fichier texte dans lequel nous pourrions souhaiter mettre des notes lors de la création d'un morceau par exemple.

Cliquez sur le bouton “Exécutable”, puis rentrez la commande pluma dans le champ d'édition. Décochez la case “Protocole NSM”. Puis cliquez sur le bouton “OK”. Fenêtre d'exécutable de RaySession : lancer pluma - cliquer pour agrandir

Un nouveau client nommé Pluma apparaît dans la liste des clients de RaySession et une nouvelle fenêtre de dialogue apparaît : c'est la fenêtre d'édition des propriétés du client ouverte sur l'onglet Ray-Hack (pseudo-protocole qui sert à gérer les clients non compatibles NSM dans la session). Le logiciel “pluma” s'ouvre. Fenêtre d'édition de proxy de RaySession : lancer pluma - cliquer pour agrandir

Voici la phase la plus délicate mais elle va vous faire gagner du temps par la suite.

Dans Pluma, avant de taper quoique ce soit, enregistrez tout de suite le document vide. Ici, “Fichier → Enregistrer” est grisé, utilisez donc “Fichier → Enregistrer sous…”.

Normalement, la fenêtre de dialogue propose d'enregistrer le fichier au bon endroit, mais si ce n'est pas le cas, vérifiez que vous êtes bien dans ~/Ray Sessions/LZK_RS premier pas/LZK_RS premier pas.pluma/.

Nommez le fichier EXACTEMENT comme la session, plus un point, plus une extension. Ce qui donne : ~/Ray Sessions/LZK_RS premier pas/LZK_RS premier pas.pluma/LZK_RS premier pas.txt

Fenêtre de sauvegarde du fichier de Pluma - cliquer pour agrandir

Retournez à la fenêtre d'édition des propriétés du client. En haut à droite de cette fenêtre, cliquez sur le bouton “Naviguer”. Une fenêtre de sélection de fichier apparaît dans le dossier du proxy. Si vous avez enregistré correctement votre fichier dans pluma, vous le voyez, il s'appelle “LZK_RS premier pas.txt”. Double-cliquez dessus. Si tout s'est bien passé, alors la fenêtre d'édition des propriétés du client doit ressembler à ceci : Fenêtre d'édition de proxy de RaySession pour Pluma, cliquez pour agrandir

Vous pouvez désormais cliquer en bas à droite de cette fenêtre sur le bouton “Arrêter”, ce qui aura pour effet d'arrêter pluma. Cliquez sur “Sauvegarder les changements”, la fenêtre des propriétés se ferme, puis relancez Pluma depuis la fenêtre principale de RaySession.

Votre client devrait ressembler à ceci : Client "Notes textes" dans Raysession - cliquer pour agrandir

Notez que le bouton de sauvegarde possède un point d'exclamation orange. Cela signifie qu'il n'y pas de moyen pour RaySession de sauvegarder son état, le fichier de texte dans Pluma ne sera donc pas sauvegardé automatiquement lorsque vous sauvegardez la session RaySession et il vous faudra vous en occuper vous-même.

Voilà, c'était long et fastidieux ?
→ Oui, un peu.

Et il faudra le refaire à chaque fois ?
→ Non, car RaySession est pensé intelligemment ! 8-)

Sauvegarder Pluma en tant que modèle

Faites un clic droit sur le client Pluma, puis sélectionnez “Sauvegarder comme modèle d'application”. Dans la fenêtre de dialogue qui apparaît, nommez votre modèle “Notes texte”, puis cliquer sur le bouton “Créer le modèle”.

Fenêtre de création de modèle de client de RaySession - cliquer pour agrandir

Dorénavant, lorsque vous voudrez lancer Pluma dans une session RaySession, vous n'aurez qu'à chercher Notes texte après avoir cliqué sur “Application” et bien pensé à cocher la case “Utilisateur”.

Ajouter une application : "Notes textes" est à présent ici - cliquer pour agrandir

Utiliser ce modèle pour Pluma

Dans Pluma, nous pouvons maintenant y mettre quelques notes utiles. 5)

Pluma avec quelques notes - cliquer pour agrandir

C'est un bon moment pour sauvegarder l'état de votre session RaySession avec Ctrl+S ou le bouton en forme de disquette vers le haut à droite de RaySession. N'oubliez pas de sauvegarder également le fichier dans Pluma !

Créer les pistes nécessaires pour l'enregistrement dans Ardour

Dans Ardour, créez deux pistes audio stéréo, l'une pour l'audio fourni par Hydrogen (stéréo), l'autre pour l'audio (stéréo aussi) fourni par ZynAddSubFx. Les deux nouvelles pistes stéréo apparaissent dans Catia.

Pour aider à la clarification, cliquez-droit sur le nom “Ardour” en haut du bloc d'Ardour dans Catia et sélectionnez “Split”. Le bloc Ardour se séparera en deux, un bloc pour les entrées et un autre pour les sorties, ce qui permettra d'organiser le canevas de Catia plus clairement : Catia avec : Hydrogen, ZynAddSubFX, Ardour et un clavier MIDI - cliquer pour agrandir

Relier les flux entre les diverses applications

Il nous faut maintenant connecter les flux des applications. Pour cela, dans le canevas de Catia, cliquez sans relâcher sur “out_1” de ZynAddSubFX et aller brancher son câble qui apparaît en bougeant le curseur avec la souris vers la piste “ZynAddSubFX/audio_in 1” du bloc Ardour. Une fois arrivé à bon port, relâchez le clic pour que le câblage soit validé.

Répéter l'opération pour la sortie “out_2” de ZynAddSubFX vers la piste “ZynAddSubFX/audio_in 2” du bloc Ardour, ainsi que pour brancher les “out_L” et “out_R” du bloc Hydrogen vers les ports de connexion “Hydrogen/audio_in 1” et “Hydrogen/audio_in 2” du bloc d'Ardour.

Profitons en pour connecter le clavier MIDI à l'entrée MIDI de ZynAddSubFX, pour cela connectez la sortie MIDI du clavier (ici Keystudio MIDI 1) à l'entrée midi ZynAddSubFX .

Voilà, nos deux applications autonomes (Hydrogen et ZynAddSubFX) sont connectées à leurs pistes respectives dans Ardour, et le clavier MIDI est connecté à ZynAddSubFx
Pour davantage de clarté, vous pouvez déconnecter les ports capture_X sortant du bloc “System” représentant les entrées du matériel audio dont nous ne nous servons pas pour ce tutoriel.

 Catia avec ZynAddSubFx et Hydrogen connectés à Ardour - cliquer pour agrandir

Préparation dans Ardour

Maintenant dans Ardour, réglez les pistes de Hydrogen et de ZynAddSubFX sur “Disque” puisque les sorties de Hydrogen et de ZynAddSubFX sont déjà connectées au matériel audio.

Tranches de mixage d'Ardour réglées sur "Disque" - cliquer pour agrandir

En réglant ces pistes sur “Disque”, cela signifie qu'Ardour ne transmettra que le son déjà enregistré.

Synchronisation au transport JACK

Dans Ardour, activez la synchronisation positionnelle externe sur le transport JACK en cliquant sur le bouton “Int” pour faire apparaître “JACK” à la place :

Ardour : activer le transport JACK - cliquer pour agrandir

Si vous aviez un souci ici, veuillez consulter le tutoriel : ardour et synchronisation au transport jack.

Dans Hydrogen, vérifiez que la synchronisation au transport JACK est bien activée en cliquant (si besoin) sur le bouton “J. TRANS” :

Hydrogen : activer le transport JACK - cliquer pour agrandir

À partir de là, vous pouvez contrôler la lecture, le stop,…etc des logiciels à partir des boutons de contrôle d'Ardour, d'Hydrogen, ou de Catia.

Créer la ligne de batterie dans Hydrogen

Pour ce tutoriel, nous allons créer ici une rythmique simple sur deux mesures en chargeant le kit de batterie “The Black Pearl 1.0” d'Hydrogen.

Choisir le son dans ZynAddSubFX

Dans la fenêtre de ZynAddSubFX, nous cliquons sur “BASS” dans la colonne “BANK”, et choisissons “WAH BASS” dans la colonne “PRESET”.

Nous allons également augmenter le “Volume” général de ZynAddSubFX car il est un peu faiblard par rapport à la rythmique d'Hydrogen. Mettons le à 90.

La preuve par l'exemple

Voilà, nous venons de paramétrer un tas de choses comme :

  • les logiciels qui sont utilisés dans cette session RaySession,
  • les liens entre eux,
  • l'instrument et le volume général de ZynAddSubFX,
  • un kit de batterie et un morceau dans Hydrogen,
  • les pistes préparées pour recevoir l'enregistrement dans Ardour,
  • un fichier-texte dans lequel placer nos notes.

Nous allons fermer cette session RaySession puis la relancer et ainsi constater que tout est rechargé automatiquement.

Pour cela, cliquez sur le bouton rond rouge troué d'une croix en haut à droite de RaySession. C'est le bouton qui permet de fermer la session (en la sauvegardant au préalable).

Maintenant, cliquez sur “Ouvrir une session”, choisissez votre session “LZK_RS premier pas” et là, la magie opère !

Aller plus loin

Vous voudrez peut être :

  1. aller consulter d'autres tutoriels à propos de ZynAddSubFX, ou de Catia, ou d'Hydrogen, ou d'Ardour, ou de Pluma, ou de RaySession,

En cas de soucis

1)
que vous êtes plusse qu'encouragé à lire si ce n'est pas déjà fait car, lire ce présent tutoriel sans avoir lu le précédent, c'est comme enfiler ses bottes sans avoir mis d'abord ses chaussettes
3)
qui est représenté par le bloc “KeyStudio” dans l'image ci-dessous
4)
et pas par le menu LZK → Applications → Son et vidéo…, ni par une ligne de commande, ou tout autre méthode
5)
Attention, messages subliminaux dans l'exemple ! 8-)
manuel/creer_une_session_raysession_avancee.txt · Dernière modification: 18/09/2020 15:26 de trebmuh